Eileen's Lounge Reverts to Subsilver After Posting

User avatar
BobH
UraniumLounger
Posts: 8031
Joined: 13 Feb 2010, 01:27
Location: Temple - Deep in the Heart of Texas

Eileen's Lounge Reverts to Subsilver After Posting

Post by BobH »

Since the upgrade to Lounge software, I've experienced a couple of things that I never experienced before. First, when I get the Login screen, the skin is Subsilver even though I have Latte Red chosen in UCP. In the past, whatever skin I chose was the skin I see on all screens. Over the weekend, I started seeing screens revert to Subsilver after I submitted a post. When I then click the bookmark tab (Firefox), the skin displays Latte Red again. :shrug:

I have no clue what is causing this. Maybe it will mean something to the gurus who manage the software.
You do not have the required permissions to view the files attached to this post.
Bob's yer Uncle!
Story of my life: I knew better but did it anyway!
Intel Core i5, 3570K, 3.40 GHz, 16 GB RAM, ECS Z77 H2-A3 Mobo, Windows 7 >HPE 64-bit, MS Office 2016

User avatar
HansV
Administrator
Posts: 69817
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Eileen's Lounge Reverts to Subsilver After Posting

Post by HansV »

Before you are logged in, the Lounge server doesn't know who you are, nor what your preferred skin is. So it displays the default skin prosilver (not subsilver).

That it reverts to prosilver after posting is a weird bug; I have seen it too. I don't have an explanation for it, sorry!
Regards,
Hans

User avatar
BobH
UraniumLounger
Posts: 8031
Joined: 13 Feb 2010, 01:27
Location: Temple - Deep in the Heart of Texas

Re: Eileen's Lounge Reverts to Subsilver After Posting

Post by BobH »

Thanks, Hans!

Yes, I realize that before login the Lounge software doesn't know what my chosen options are; however, in all the years with different skins, I never experienced this issue. It began only after the Lounge software upgrade, now it's happening after I submit a post, too.
Bob's yer Uncle!
Story of my life: I knew better but did it anyway!
Intel Core i5, 3570K, 3.40 GHz, 16 GB RAM, ECS Z77 H2-A3 Mobo, Windows 7 >HPE 64-bit, MS Office 2016

User avatar
BobH
UraniumLounger
Posts: 8031
Joined: 13 Feb 2010, 01:27
Location: Temple - Deep in the Heart of Texas

Re: Eileen's Lounge Reverts to Subsilver After Posting

Post by BobH »

FWIW in diagnosing (or maybe just to get attention, eh?) I got this reversion to Subsilver after making the post in the screenshot.
skin change.PNG
You do not have the required permissions to view the files attached to this post.
Bob's yer Uncle!
Story of my life: I knew better but did it anyway!
Intel Core i5, 3570K, 3.40 GHz, 16 GB RAM, ECS Z77 H2-A3 Mobo, Windows 7 >HPE 64-bit, MS Office 2016

GeoffW
GoldLounger
Posts: 3445
Joined: 24 Jan 2010, 07:23

Re: Eileen's Lounge Reverts to Subsilver After Posting

Post by GeoffW »

You get the reversion to subsilver because it's logged you off. It's showing "Login" at the top RHS of your screen instead of your name. Logging off is one of the frequent symptoms of whatever is happening.

User avatar
HansV
Administrator
Posts: 69817
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Eileen's Lounge Reverts to Subsilver After Posting

Post by HansV »

It's a weird phenomenon. I've been apparently logged out after some actions, only to be logged in again after merely refreshing the page. On other occasions I really had to log in again...
Regards,
Hans

User avatar
BobH
UraniumLounger
Posts: 8031
Joined: 13 Feb 2010, 01:27
Location: Temple - Deep in the Heart of Texas

Re: Eileen's Lounge Reverts to Subsilver After Posting

Post by BobH »

I'm getting the same phenomenon today every time I post: the 'skin' reverts to Prosilver (sorry) from Latte Red. I then click on an icon (linked to a bookmark) that reverts back to Latte Red.
Bob's yer Uncle!
Story of my life: I knew better but did it anyway!
Intel Core i5, 3570K, 3.40 GHz, 16 GB RAM, ECS Z77 H2-A3 Mobo, Windows 7 >HPE 64-bit, MS Office 2016

User avatar
Graeme
3StarLounger
Posts: 369
Joined: 11 Feb 2010, 12:23
Location: Medway, Kent, UK

Re: Eileen's Lounge Reverts to Subsilver After Posting

Post by Graeme »

I'm a bit late to the party and whilst not a direct answer, but as part of the fault finding exercise, does the forum log you off after posting if the default Prosilver skin is active?

My guess is that it's a bug with the Latte Red style extension. Any css programmers here?

Regards

Graeme

User avatar
BobH
UraniumLounger
Posts: 8031
Joined: 13 Feb 2010, 01:27
Location: Temple - Deep in the Heart of Texas

Re: Eileen's Lounge Reverts to Subsilver After Posting

Post by BobH »

Graeme, I don't recall but I will pay attention now and see what happens after reverting to Prosilver.

As it has been some time since I posted this originally, I reviewed the thread. When Hans said that the Lounge software doesn't know who I am when I log in inferring that the default skin, I wondered what purpose Lounge cookies serve. My guess has always been that it contained some identifying information, else why have it. Can you help me with my confusion on this?
Bob's yer Uncle!
Story of my life: I knew better but did it anyway!
Intel Core i5, 3570K, 3.40 GHz, 16 GB RAM, ECS Z77 H2-A3 Mobo, Windows 7 >HPE 64-bit, MS Office 2016

User avatar
HansV
Administrator
Posts: 69817
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Eileen's Lounge Reverts to Subsilver After Posting

Post by HansV »

Eileen's Lounge places three cookies:
One whose name ends in _k. This is an identifier used if you tick 'Remember me' when you log in.
One whose name ends in _sid. This contains a unique session identifier. It will change each time you visit the Lounge.
One whose name ends in _u. This contains your user_id, a unique number that identifies you. You can see your user_id when you hover the mouse pointer over your avatar or over the username under it.
You can view the cookies in Firefox by pressing F12 to display the developer tools.
Activate the Storage tab.
Expand Cookies, then click on the Eileen's Lounge URL.
Regards,
Hans

User avatar
Graeme
3StarLounger
Posts: 369
Joined: 11 Feb 2010, 12:23
Location: Medway, Kent, UK

Re: Eileen's Lounge Reverts to Subsilver After Posting

Post by Graeme »

BobH wrote:
13 Nov 2020, 18:58
Graeme, I don't recall but I will pay attention now and see what happens after reverting to Prosilver.

And, still just guessing, are there any dodgy symptoms if using Latte? Latte Red is just a colour variation of the Latte style and needs Latte installed to function.

And can I ask, anybody, if you select Latte from the selection box on the portal and then select Latte Red, do you see a change? I don't seem to.

Regards

Graeme

User avatar
HansV
Administrator
Posts: 69817
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Eileen's Lounge Reverts to Subsilver After Posting

Post by HansV »

The difference between Latte and Latte Red is in the colour of unread posts: green for standard Latte, red for Latte Red.

S0032.png
You do not have the required permissions to view the files attached to this post.
Regards,
Hans

User avatar
Graeme
3StarLounger
Posts: 369
Joined: 11 Feb 2010, 12:23
Location: Medway, Kent, UK

Re: Eileen's Lounge Reverts to Subsilver After Posting

Post by Graeme »

HansV wrote:
13 Nov 2020, 20:26
The difference between Latte and Latte Red is in the colour of unread posts: green for standard Latte, red for Latte Red.

Ah, well, if that's all then I can see why I didn't notice!

And if Latte works for Bob without the quirks of Latte Red, perhaps a fix of sorts.

Regards

Graeme