Assign Macro command not active

YasserKhalil
PlatinumLounger
Posts: 4939
Joined: 31 Aug 2016, 09:02

Assign Macro command not active

Post by YasserKhalil »

Hello everyone

I have a problem with form button control, when right-click I found that Assign Macro command not enabled (not active). The worksheet is not protected at all neither the workbook. When trying with a shape, I found the command is active.
I tried to repair the office installation and after repairing the same problem still persists.
Any idea how to solve this problem?

User avatar
HansV
Administrator
Posts: 79030
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Assign Macro command not active

Post by HansV »

Does this happen with all form controls command buttons in all workbooks, even in a newly created workbook?
Best wishes,
Hans

YasserKhalil
PlatinumLounger
Posts: 4939
Joined: 31 Aug 2016, 09:02

Re: Assign Macro command not active

Post by YasserKhalil »

The problem happens even if it is a new created workbook. Only the problem solved when trying the command `excel / safe` (opening the excel in safe mode). I even restarted my pc twice but the problem is still there.

User avatar
HansV
Administrator
Posts: 79030
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Assign Macro command not active

Post by HansV »

If the problem goes away in Safe Mode, it could be caused by an add-in.
Try disabling add-ins one by one, and each time test whether the problem persists. If not, the add-in that you disabled last is the culprit.
Best wishes,
Hans

YasserKhalil
PlatinumLounger
Posts: 4939
Joined: 31 Aug 2016, 09:02

Re: Assign Macro command not active

Post by YasserKhalil »

But I didn't install any add-ins at all.

User avatar
HansV
Administrator
Posts: 79030
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Assign Macro command not active

Post by HansV »

Select File > Options > Add-ins.
Make sure that nothing is listed under Active Application Add-ins.
Then select Disabled Items from the Manage drop-down near the bottom, and click Go...
Anything there?

S2408.png
You do not have the required permissions to view the files attached to this post.
Best wishes,
Hans

YasserKhalil
PlatinumLounger
Posts: 4939
Joined: 31 Aug 2016, 09:02

Re: Assign Macro command not active

Post by YasserKhalil »

I have this when I followed the steps
01.png
You do not have the required permissions to view the files attached to this post.

YasserKhalil
PlatinumLounger
Posts: 4939
Joined: 31 Aug 2016, 09:02

Re: Assign Macro command not active

Post by YasserKhalil »

Solved by regedit

Code: Select all

Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Excel
then delete Options folder and restart excel application